Error making my own application

Hi, evereyone, i’m trying to build my own app. I follow the steps in Building User Applications — OpenFHE documentation, but when i execute the make comand the output is:

c++: error: unrecognized command line option ‘-fopenmp=libomp’; did you mean ‘-fopenmp-simd’?
c++: error: unrecognized command line option ‘-fopenmp=libomp’; did you mean ‘-fopenmp-simd’?
make[2]: *** [CMakeFiles/test.dir/build.make:63: CMakeFiles/test.dir/demo-simple-example.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:76: CMakeFiles/test.dir/all] Error 2
make: *** [Makefile:84: all] Error 2

The installation is correct as I can run the example bin/examples/pke/simple-integers correctly.

This error does not always appear as other times I have tried to run my own application and it has worked correctly.

Hi there!

It’s a little difficult to help without seeing the code and/or the CMAKE. Do you have a URL I can take a look at?


To create my own application I tried using the sample code available at openfhe-development/simple-integers-serial.cpp at main · openfheorg/openfhe-development · GitHub.

@jtovartr Could you also share the CMakeLists.txt file for your project?

Also, are you able to build OpenFHE w/o any problems? What compiler are you using?


Are you still running into this issue? If not I’ll mark it as solved

I’m sorry for taking so long to respond but I’ve already solved it. The solution was to reinstall openfhe and now it works correctly.

This topic was resolved and your question isn’t related to the original question. Please open a new thread