Running "error" (nothing is displayed) with msys2 on Windows 11

Hi everyone,

I installed OpenFHE on Windows 11, with msys2, according to this

I have followed every command, and every test with the “make testall” worked fine

I then created another repo, outside the openfhe-development repo, and build it like this

But when I’m trying to run a simple test on my other repo in which I linked OpenFHE, it gives me no return, and no error message, just nothing happens.

On the right, my code
On the left, the “./test.exe” with no response, no “Hello, world!”

I noticed that this happens everytime I write something using the OpenFHE library.
But just including the library, and not using it works fine.

Does anyone know what the problem could be ?

@HugoJazz Hi, on Windows you should always add the location of your libraries to PATH. This is what to run in the command prompt: “export PATH=${PATH}:full_library_install_location”.
if you installed OpenFHE in /home/hugojazz/local, then you should replace full_library_install_location with /home/hugojazz/local/lib.

1 Like

Hi !

It worked !! Thank you so much @dsuponitskiy-duality :slight_smile:

Hello sir!. I face the same issue when I try to run an executable file. On Windows, how exactly do I have to run .exe file with the absolute location of libraries?

Those are not the correct directory names for the binaries. I would suggest installing the binaries somewhere in your home directory in MinGW, as it is easier to specify their location. Personally, I never use any location that starts with ‘C:/’.
If you want to leave the libraries in “c:/Program FIles” then your path should start with:
/c/“Program Files”/.

Thank you, sir. Let me try.

I tried to run my executable file with exactly the absolute path. However, there is no error or output.

please read the instructions at Installing OpenFHE on Windows — OpenFHE documentation. there is an example how to set up PATH.

Thank you, sir. I am posting this just for the record so others can get some hints in the future. If openfhe does not install inside MinGW (installed somewhere else), add the absolute path (.dll containing bin folder path) inside the msys64/etc/profile like this.
Alternatively, add the path(s) to ORIGINAL_PATH variable in c:/msys64/etc/profile to make this change permanent. (Follow this as mentioned in standard documentation)

Some of my code ran examples. Thank you so much, sir! @dsuponitskiy-duality

You must remember that MinGW is NOT Windows, but a Unix-like system.

1 Like